NASの調子が悪い

P_20170708_115522_vHDR_Auto.jpg この頃ときどき、自宅のNASの調子が悪くなる。
原因不明だけれど、症状としては、異常な通信を出し続けるというもの。
その結果、LAN全体が輻輳により、通信ができなくなる。
この半年ほどの間で、既に5~6回、同じ現象が起こっている。

使用している機種は、I-O DATAのHDL2-S2.0、2TB(ミラー構成で1TBで使用)。既に生産終了となっている製品で、我が家では、かれこれ6年ぐらい使っている。モノがモノだから、ずっと休まずに働いてきたわけだ。

その前にもNASを使っていたのだけれど、そちらは2年程使ったところで、部分的に読み出しができなくなった。その経験があるから、後継機はミラー構成にした。
HDL2-S2.0の方は、いままでディスクのエラーは出ていない。

はじめて異常通信を起したときは、何が起こったのかさっぱりわからず、LAN障害だろうと思って、ルーターの再起動などを試みてうまくいかなかった。また、障害が出るのは有線LANだけで、無線LANは通常どおり利用できたので、これはルーター自体の障害だろうと考えた。

ルーターはプロバイダから無償貸与されているものだから、コールセンターに電話をかけたところ、コールセンターでは、まず原因特定をきちんとしましょうと、無理難題―簡単なことなんだけど、ルーターの場所を動かしたり、結線を変更するのは本当に面倒―を言われ、ルーター交換するにしてもやっぱり結線変更とかしなくちゃならないわけだから、気を取り直して、結線を変更してテストなどをしてみた次第。

それで結線を変更しているときに、NASに繋がるラインも抜いたわけで、有線LANが生き返った。もちろん、NASが原因とは夢にも思ってなかったから、どれが悪いのかとケーブルを変えたり(家の各部屋までは壁の中にLAN配線がしてあるからそこは無理)しているうちに、調子よく動いていてもNASをつないだ途端にダメになるということにようやく気付いて、NASをあらためてチェックした。

もちろんNAS自体は異常通信を出しているから、こちらからのアクセスに答えるわけもなく、そして、電源ボタンも効かない。電源ケーブルを抜いて無理矢理停止。

あらためて電源ケーブルを挿し、電源(起動)ボタンを押して、無事再起動。
NASへも正常にアクセスでき、有線LANはもちろん平常通り。

まずNASのログで、ディスク障害が出ていないか調べてみたが、そういう痕跡はない。
異常なのは通信のみ。
ウィルス感染とかで、データを外部に送出していたら困ったことだが、そうした兆候は見られないし、異常時も無線LAN経由でのインターネット接続は問題がなかったから、外部へデータを送出していた可能性は低いと思う。

sambaの脆弱性が報道されていたが、それはWindowsでの問題で、安物のNASはだいたいがLinux。


対処方法はわかったわけだけれど、そうたびたび起こるのは具合が悪い。
そろそろNASも変え時かもしれない。

次はどうしよう。
やっぱりミラー構成がいいだろうなぁ。

ミラー構成で一方のディスクが障害を起こしても、そのディスクを交換する気はさらさら無い。交換ディスクの方が多分高額だろう。
もう一方のディスクが正常のうちに、別の機器を購入して、そこへコピーするのが良いと思う。

SSDも魅力的だなぁ。音がしないだろうし。

関連記事
スポンサーサイト

コメントの投稿

非公開コメント

Gallery
検索フォーム

⇒記事一覧

プロフィール

六二郎。六二郎。


定年退職
苦しい家計の足しに再就職
=いつクビになってもええねん
 言うたもん勝ちや!のブログ
リンク
最新記事
最新コメント
最新トラックバック
アーカイブ
カテゴリ
タグ

書評 ITガジェット マイナンバー Audio/Visual 

リンク
現在の閲覧者数
聞いたもん